Punto esclamativo “!”

La volta scorsa abbiamo affrontato il dollaro, andiamo avanti.

Abbiamo detto che in un software come Excel, il numero di celle disponibili è potenzialmente infinito poiché è possibile aggiungere quanti fogli vogliamo. Questo risulta molto comodo per suddividere i dati dal punto di vista logico, per esempio creare un foglio chiamato “Semestre1” e uno chiamato “Semestre2” per poter riportare in modo ordinato le spese domestiche sostenute. Ma come poter fare riferimento a celle che risiedono in un foglio diverso da quello corrente? Il punto esclamativo serve esattamente a questo, tra poco vedremo come funziona ma prendiamoci un momento per chiarire questo antipatico termine “foglio” che spesso crea confusione.

 

Pillole di Excel - 04 - Punto esclamativo tridimensionali - Lamberto Salucco

 

Normalmente la parola “foglio” si riferisce all’elemento interno di Excel. Spesso un nuovo file contiene già tre fogli diversi chiamati “fogli elettronici” o “fogli di lavoro”.

Il file, invece, che viene salvato viene chiamato “foglio di calcolo” o “cartella di lavoro”. Questo file dal 2007 ha come estensione predefinita nel mondo Microsoft il formato .xlsx che è molto più sicuro del precedente .xls perché non può contenere macro (ovvero codice che permette cose mirabolanti ma che potrebbe essere infettato, magari ne parleremo nel prossimo Manabile semiserio). Nota bene: Calc ha anche un proprio formato .ods che sta per Open Document Spreadsheet. Il formato .xlsx viene aperto sia da MS Excel sia da Calc ma talvolta ci si trova davanti a strane limitazioni (per esempio OpenOffice Calc lo può aprire ma non lo può salvare mentre Libre Office Calc dà anche la possibilità di salvarlo).

Ok, torniamo sul seminato e vediamo come utilizzare questo benedetto punto esclamativo in MS Excel. In pratica è necessario far seguire il punto esclamativo al nome del foglio esterno, tipo: nomeFoglio!A1.

Attenzione: in Calc si utilizza il punto “.” al posto del punto esclamativo “!” quindi il risultato sarà: nomeFoglio.A1

Usiamo l’esempio precedente e mettiamolo in pratica. In un file abbiamo quindi creato tre fogli chiamati “Semestre1”, “Semestre2”, “Totale”. Abbiamo inserito qualche voce di spesa nei primi due e vorremmo riportare nel foglio “Totale” la somma di tutte le spese sostenute nei due semestri. Assumendo per comodità nell’esempio che gli intervalli di celle da sommare siano uguali in entrambi i fogli, dovremmo dire a Excel di fare la somma delle celle che stanno fra la B2 e la B6 del foglio “Semestre1” e delle celle che stanno fra la B2 e la B6 del foglio “Semestre2”.

Sarà quindi necessario scrivere nella cella del foglio “Totale” in cui vogliamo vedere il risultato, per esempio la cella A2, la seguente funzione =SOMMA(Semestre1!B2:B6;Semestre2!B2:B6)
Semestre1!B2:B6 significa l’intervallo di celle fra la B2 e la B6 contenute nel foglio di lavoro chiamato “Semestre1”
Semestre2!B2:B6 significa l’intervallo di celle fra la B2 e la B6 contenute nel foglio di lavoro chiamato “Semestre2”

 

Pillole di Excel - 04 - Punto esclamativo tridimensionali - Lamberto Salucco

 

Entrambi sono argomenti della funzione SOMMA, separati dal punto e virgola.

I fogli possono ovviamente essere rinominati senza limitazioni, generalmente cliccando due volte sul nome oppure cliccando col tasto destro. Se rinominassimo il foglio “Semestre1” in “PrimaParte”, Excel modificherebbe automaticamente il contenuto della cella A2 in =SOMMA(PrimaParte!B2:B6;Semestre2!B2:B6) senza problemi.

Un rapido appunto: normalmente su Excel potete scrivere tutto minuscolo senza problemi: nomi delle funzioni, nomi delle celle etc. Poi ci pensa il software a mettere tutto in maiuscolo per esempio =somma(a1:a10) che diventa così =SOMMA(A1:A10). Per i nomi dei fogli però consiglierei un po’ di attenzione in più. Mi è capitata in passato una serie di problemi, specialmente lavorando fra MS Excel e Calc, dovuti ai nomi dei fogli: se lo chiamate “FoglioGennaio” rispettate maiuscole e minuscole quando lo scrivete, per esempio, in una funzione. Non costa molta fatica e può evitare qualche grattacapo.

 

Pillole di Excel - 04 - Punto esclamativo tridimensionali - Lamberto Salucco

 

Nota bene: un’operazione davvero pericolosa in MS Excel è l’eliminazione di un foglio. Sembra incredibile ma non è possibile annullarla in nessun modo. Non eliminate mai un foglio senza controllarne bene prima il contenuto. Stranamente Calc, invece, permette l’annullamento dell’eliminazione di un foglio. Boh…

 

 

 

Formule tridimensionali

Già che ci sono, voglio accennare anche a una strana sintassi chiamata formule tridimensionali che si incontra raramente ma che proprio per questo può essere di difficile lettura per un principiante.

 

Pillole di Excel - 04 - Punto esclamativo tridimensionali - Lamberto Salucco

 

 

L’argomento richiederebbe più tempo ma mi limiterò qui a fare un esempio per completezza di informazione sul punto esclamativo. La funzione =SOMMA(GEN:MAR!B5) va letta come somma delle celle B5 di tutti i fogli che stanno fra il foglio “GEN” e il foglio “MAR” compresi. È quindi un intervallo (:) di fogli (!). Vi consiglio, qualora vi interessi, di cercare qualche esempio o tutorial in rete, ce ne sono diversi.

 

 

Tratto da “Manabile Semiserio di Excel – Parte Prima per principianti

Manabile semiserio di Excel - Lamberto Salucco | Rebus Multimedia