Le parentesi quadre “[ ]”

Ok, siamo arrivati al quinto e ultimo elemento di sintassi: le parentesi quadre.

Sarò breve: sono come un mega punto esclamativo, dato che servono per far riferimento a un valore che risiede in un file diverso da quello corrente. La sintassi che li contraddistingue è abbastanza antipatica, scriverò qui un esempio tipico per darne un’idea:

=A1+’C:\Documents and Settings\Admin\Docs\[Book.xlsx]Foglio1′!$A$1

Analizziamolo insieme:

A1 è la cella A1 del foglio in cui sto scrivendo e a cui va sommato…

  • Il valore contenuto nella cella $A$1 (riferimento assoluto)
  • Che sta in un foglio chiamato “Foglio1”
  • Che sta in un file chiamato “Book.xlsx”
  • Che sta nel percorso “Documents and Settings\Admin\Docs\”
  • Che sta sull’unità C:
  • Notare che solo il nome del file esterno viene messo fra parentesi quadre
  • Notare che all’inizio del percorso viene aperto un apice singolo che viene chiuso subito dopo il nome del foglio

La stessa cosa su Calc sarebbe stata invece scritta così:

=A1+’file:///C:\Documents and Settings\Admin\Docs\Book.ods’#$Foglio1.A1

Dato che le parentesi quadre si usano quindi su MS Excel per chiamare una cella che sta in un file esterno e dato che le parentesi graffe non si digitano (e al limite le inserisce Excel per le formule matriciali che forse tratterò in un secondo volume) ne consegue che le uniche parentesi che si utilizzano in Excel sono quelle tonde.

E, se necessario, si nidificano le tonde nelle tonde, in altre tonde etc.

 

Operazioni e formule

Parlando di semplici operazioni aritmetiche mi è venuto in mente che spesso le persone si annodano quando devono risolvere i calcoli più elementari, semplicemente perché non si ricordano l’ordine di importanza delle operazioni, ovvero quali devono essere svolte per prime.

Ricordiamo che le operazioni in questione sono la sottrazione (-), la divisione (/), la moltiplicazione (*), l’elevamento a potenza (^), l’addizione (+).

 

Pillole di Excel - 05 - Sintassi D - Lamberto Salucco

 

Per esempio, quanto fa 4+5-3*2+1?

  • Fa 13? (4+5 = 9, -3 = 6, per 2 = 12, +1 = 13)
  • Fa 18? (5-3 = 2, +4 = 6, 2+1 = 3, per 6 = 18)
  • No: fa 4. (3 per 2 = 6, 9-6+1 = 4).

L’ordine delle operazioni è il cosiddetto PEMDAS che ricorda: Parentesi, Esponenti (potenze), Moltiplicazioni, Divisioni, Addizioni, Sottrazioni.

Aggiungo che fra moltiplicazione e divisione non c’è un vero e proprio vincitore, semplicemente si svolgono nell’ordine di lettura partendo da sinistra.

Lo stesso discorso è valido per addizione e sottrazione.

L’unico modo, quindi, di modificare l’ordine di esecuzione delle operazioni è utilizzando le parentesi, ovviamente su Excel quelle tonde.

Per esempio, riprendendo l’operazione di prima:
4+5-3*2+1 = 4 ma 4+(5-3)*2+1 = 9 mentre 4+5-3*(2+1) = zero.

Tutte queste operazioni che abbiamo citato sono formule aritmetiche che si possono utilizzare normalmente all’interno di Excel.

Possiamo per esempio scrivere in una cella =A1+A2+A3 usando una formula.

Ma potremmo anche usare una funzione, ovvero un comando con un determinato nome e una determinata sintassi.

In questo caso potremmo scrivere =SOMMA(A1;A2;A3) oppure =SOMMA(A1:A3)

Difficilmente le persone utilizzano correttamente questi due termini, complice anche una certa confusione nella traduzione di questi termini dalla lingua inglese.

Consiglio di conoscere almeno le parole importanti: si evitano figuracce e si ottiene più facilmente aiuto nei forum/gruppi.

 

 

Tratto da “Manabile Semiserio di Excel – Parte Prima per principianti

Manabile semiserio di Excel - Lamberto Salucco | Rebus Multimedia