Funzioni base

Continuiamo il discorso sulle funzioni, mi pare il momento giusto. La struttura di una funzione in Excel è sempre la stessa:

=FX([arg1];[arg2];…)

Cerchiamo di imparare a leggerla.

  1. Innanzitutto si inizia con un segno “=”. Il contenuto di una cella su Excel, infatti, può essere di due tipi: statico o dinamico. Se è statico significa che non cambierà in base ad altre celle, per esempio se scrivo “gennaio” in una determinata cella, ci rimarrà scritto anche se arriva l’Apocalisse. Se invece scrivo in una cella “=A1+A2” il contenuto di quella cella non sarà statico ma dinamico, ovvero cambierà dinamicamente secondo il contenuto delle celle A1 e A2. Possiamo quindi affermare che il contenuto dinamico delle celle inizia con il segno “=” e che una funzione nasce appositamente per creare contenuto dinamico.
  2. FX è il nome della funzione. Intendiamoci subito: credo che ormai (gennaio 2020) siano quasi 450 e che sia impossibile per chiunque conoscerne bene la metà. Sono suddivise in categorie per semplificare la vita all’utente che le deve ritrovare: logiche, data/ora, finanziarie etc. La verità è che personalmente utilizzo sempre le stesse 25/30 funzioni, anche nei progetti più complessi (ma il vostro flusso di lavoro potrebbe richiedere roba più complessa).
  3. Ogni funzione ha la propria sintassi e quindi accetta uno o più argomenti. Questi argomenti sono le opzioni, i parametri che la funzione elabora per restituire un risultato. Esistono funzioni che ne accettano cinque e funzioni che non ne accettano nemmeno uno. Bisogna studiarle e imparare a utilizzare l’help in linea ovvero quel piccolo suggerimento sulla sintassi che compare quando si digita il nome di una funzione.
  4. Le parentesi quadre che si vedono nell’help in linea (lo so che sono fuorvianti ma non c’entrano nulla con quelle di cui abbiamo appena parlato, ringraziamo per l’immancabile chiarezza e trasparenza mamma Microsoft…) stanno a significare che quello è un argomento facoltativo, cioè che non è necessario per la sintassi di quella funzione (potrebbe però modificare completamente il comportamento della stessa).

Pillole di Excel - 06 - Funzioni base - Lamberto Salucco

 

 

Tenendo a mente lo schema appena analizzato, si nota che per esempio la funzione di somma =SOMMA(A1;B3;C2:C5;D6) inserita in una cella mostrerà la somma delle celle A1, B3, C2, C3, C4, C5, D6. È importante, anche se spesso l’utente non lo sa, alla fine della digitazione di un contenuto premere il tasto Invio per completare l’operazione. Si tratta di un errore commesso statisticamente più spesso dagli utenti di sesso femminile che, invece di premere Invio, tendono talvolta a cliccare su un’altra cella per terminare l’inserimento. Questo comportamento può portare a problemi in alcune particolari situazioni e dovrebbe essere evitato.

Vediamo adesso altre semplici funzioni che condividono con la SOMMA (in inglese Sum) la stessa sintassi:

  • MEDIA: inserendo in una cella =MEDIA(A1:A10) si otterrà la media dei valori contenuti nelle celle comprese fra A1 e A10. In inglese si chiama Average.
  • MIN: inserendo in una cella =MIN(A1:A10) si otterrà il valore più piccolo tra quelli contenuti nelle celle comprese fra A1 e A10.
  • MAX: inserendo in una cella =MAX(A1:A10) si otterrà il valore più grande tra quelli contenuti nelle celle comprese fra A1 e A10.
  • CONTA.NUMERI: inserendo in una cella la funzione =CONTA.NUMERI(A1:A10) si saprà quante celle comprese fra A1 e A10 hanno contenuto di tipo numerico. I valori calcolabili sono numeri, orari e date. In Excel questi dati vengono automaticamente allineati a destra mentre quelli non calcolabili vengono allineati automaticamente a sinistra. In inglese si chiama COUNT. Pillole di Excel - 06 - Funzioni base - Lamberto Salucco
  • CONTA.VALORI: inserendo in una cella =CONTA.VALORI(A1:A10) si saprà quante celle comprese fra A1 e A10 hanno un contenuto qualunque (calcolabile o non calcolabile) ovvero non sono vuote. In inglese si chiama COUNTA. Attenzione: una cella che contenga solamente uno spazio sembrerà vuota ma la funzione CONTA.VALORI la vedrà “piena”.

Buono, abbiamo fatto parecchia roba, basta così.

Nel prossimo capitolo parliamo di tabelle, filtri e nomi.

 

 

 

Tratto da “Manabile Semiserio di Excel – Parte Prima per principianti

Manabile semiserio di Excel - Lamberto Salucco | Rebus Multimedia