Anche in questo caso, dal 2007 è disponibile la funzione SOMMA.PIÙ.SE (disponibile anche su Calc, chiamata in inglese SUMIFS) che aumenta a dismisura i criteri a disposizione dell’utente.

Facciamo subito un esempio che possa chiarire la sintassi di questa funzione: essendo necessario definire un argomento Int_somma ed essendo tecnicamente possibile inserire fino a 127 coppie di argomenti intervallo-criterio, Microsoft ha deciso di ribaltare la sintassi della SOMMA.SE, ponendo come primo argomento proprio l’Int_somma.

 

Pillole di Excel - 12 - Somma.più.se - Lamberto Salucco

 

Ecco quindi la funzione impostata per sommare gli introiti dei dischi prodotti tra il 2000 e il 2005:

=SOMMA.PIÙ.SE(E2:E16;C2:C16;”>2000″;C2:C16;”<2005″)

La funzione è così composta dai cinque argomenti:

  1. E2:E16 è l’intervallo di celle da sommare
  2. C2:C16 è l’intervallo dove cercare il primo criterio
  3. “>2000” è il primo criterio
  4. C2:C16 è l’intervallo dove cercare il secondo criterio
  5. “<2005” è il secondo criterio.

Facciamo adesso l’ultimo (giuro) esempio per questa funzione (non se ne può più, lo so) mettendo due diversi criteri in due celle esterne, applicandoli a due intervalli di celle diversi.

 

Pillole di Excel - 12 - Somma.più.se - Lamberto Salucco

 

=SOMMA.PIÙ.SE(E2:E16;C2:C16;”>2000″;A2:A16;”Dream Theater”)

La funzione è così composta dai cinque argomenti:

  1. E2:E16 è l’intervallo di celle da sommare
  2. C2:C16 è l’intervallo dove cercare il primo criterio
  3. “>”&A18 è il primo criterio, creato concatenando l’operatore al contenuto della cella A18
  4. C2:C16 è l’intervallo dove cercare il secondo criterio
  5. B18 è la cella che contiene il secondo criterio.

Bravi, è finito anche questo capitolo. Nel prossimo si parla di visualizzazione e di stampa.

 

 

 

Tratto da “Manabile Semiserio di Excel – Parte Prima per principianti

Manabile semiserio di Excel, prima parteStrade scomparse di Firenze, prima parte - - Lamberto Salucco | Rebus Multimedia