Pillole di Excel – 44 – Ricercare i dati

Partiamo con una cosa molto semplice: vogliamo sapere quante città presenti nella tabella hanno un nome che inizia con la lettera “B”.

I caratteri jolly che normalmente vengono usati in questo tipo di ricerca sono due: l’asterisco e il punto interrogativo. Siamo nel mondo Microsoft (funziona perfettamente su MS Excel e anche su Libre Office ma non su OpenOffice) e si usano quindi le stesse tecniche della ricerca dei file in Windows.

Pillole di Excel - 44 - Ricercare i dati - Lamberto Salucco

Infatti l’asterisco “*” può sostituire n caratteri (0, 1, 5, 1000 etc) mentre il punto interrogativo “?” ne sostituisce solo uno.

Dicevamo che la nostra prima missione è sapere quante città iniziano con la lettera “B”. In questo caso la cosa importante è che il primo carattere sia una “B” ma ovviamente i restanti potrebbero essere zero come settanta, situazione perfetta per usare un asterisco. Ecco infatti cosa c’è scritto nella cella F2:

=CONTA.SE(A2:A12;”b*”)

Il risultato è quindi 3 perché trova Bergamo, Bari e Bologna.

Se invece volessimo sapere quante città della tabella hanno un nome composto da 6 cifre potremmo usare una serie di punti interrogativi come segnaposto per i caratteri.

L’utilizzo dei punti interrogativi per contare i caratteri non è molto frequente, generalmente si preferisce usare funzioni di testo specifiche come per esempio LUNGHEZZA. E in effetti non è per nulla una cattiva idea, anche considerando il fatto che la funzione LUNGHEZZA, a differenza dei punti interrogativi che sono più adatti ai testi, lavora bene anche in presenza di celle con contenuto numerico. Il mio punto di vista però è diverso: a me non interessa solo e unicamente conoscere ciò che è perfetto ma poter leggere e poter capire cosa c’è scritto in una cella. Saper fare una cosa in più modi espande il cervello e abitua la mente a risolvere un problema in modi più creativi.

Pillole di Excel - 44 - Ricercare i dati - Lamberto Salucco

Ma ho riperso il filo. Volevamo sapere quante città hanno il nome composto da sei caratteri. Ecco cosa c’è scritto adesso in F2:

=CONTA.SE(A2:A12;”??????”)

Excel trova Napoli, Milano, Torino e risponde 3: tutto ok.

È lapalissiano che se dovessi sostituire uno dei punti interrogativi con una lettera modificherei in modo importante la ricerca. Per esempio scrivendo la seguente funzione direi a Excel che voglio sapere quante città hanno il nome composto da sei caratteri e iniziano per “M”:

=CONTA.SE(A2:A12;”M?????”)

e così via, le combinazioni sono ovviamente infinite.

A onor del vero esiste anche un altro carattere jolly che però non è un carattere jolly ma che serve per usare i caratteri jolly come caratteri non jolly. Si tratta della tilde “~”.

Facciamo chiarezza: non è semplice cercare un asterisco se Excel lo considera un carattere particolare. La tilde fa esattamente questo, fa leggere a Excel l’asterisco o il punto esclamativo come se fossero caratteri normali.

Pillole di Excel - 44 - Ricercare i dati - Lamberto Salucco

In questo esempio vogliamo sapere quante città hanno l’asterisco in fondo al nome. Ma non possiamo usare l’asterisco se non con una tilde che ci aiuti a renderlo leggibile a Excel. Ecco quindi cosa ho scritto nella cella E2:

=CONTA.SE(A2:A12;”*~*”)

Bene, direi che le cose fondamentali su questo le abbiamo dette.

 

 

Tratto da “Manabile Semiserio di Excel – Parte Seconda per utenti bravini

Qui il link per acquistare il libro su Amazon

Manabile Semiserio di Excel - Seconda parte per utenti bravini - Lamberto Salucco | Rebus Multimedia

Altri articoli

FCT: “Misteriosi malfunzionamenti nel laboratorio di Adalberto”

Misteriosissimi e inquietanti danni e malfunzionamenti del laboratorio di Adalberto Nabucco! Sembra incredibile ma da...

El baul de Arriaga

Primo e-book Edida in lingua spagnola.

Il rosso e il nero della comunicazione

Pubblicato il primo e-book con marchio Edida.

Pubblicato l’ebook “La nuova ECDL in pillole”!

Abbiamo finalmente pubblicato l'ebook "La nuova ECDL in pillole". Lo scopo di questo libro è...

Ep. 21: “O i baccelli o la vita!?”

Era una notte di fine estate a Firenze City quando l’auto con a bordo...

Pillole di Excel – 12 – Somma.più.se

SOMMA.PIÙ.SE Anche in questo caso, dal 2007 è disponibile la funzione SOMMA.PIÙ.SE (disponibile anche su...
spot_img

Lamberto Salucco

(Firenze, 1972) – Sono un consulente informatico (ma laureato in Lettere Moderne), mi occupo di marketing (ma solo digitale), social media (ma non tutti), editoria (ma non cartacea), musica (ma detesto il reggae), formazione (ma non scolastica), fake news (ma non sono un giornalista), programmazione (ma solo Python), siti web (ma solo con CMS), sviluppo app (ma solo iOS e Android), bias cognitivi (ma non sono uno psicologo), intelligence informatica (ma solo OSINT), grafica 3D (ma niente CAD), grafica 2D (ma niente Illustrator), Office Automation (ma non mi piace Access).
 

Forse ti potrebbe interessare anche: