Excel – 02 – punto e virgola, due punti, riferimento circolare

E dopo l’introduzione eccoci alla roba seria. Generalmente in aula presento un elenco di cinque elementi di sintassi che secondo me sono fondamentali e che dovrebbero essere conosciuti da tutti gli utenti: punto e virgola, due punti, dollaro, punto esclamativo, parentesi quadre.

Vediamo se riesco a farne una sintesi accettabile.

 

Punto e virgola “;” e due punti “:”

Qual è la differenza nell’utilizzo di questi due elementi quando si fa riferimento alle celle? La risposta è molto semplice: separando i nomi di due celle con il punto e virgola, si intendono le due singole celle.

Per esempio, se scrivo A1;B5 intendo la cella A1 e la cella B5. In MS Excel posso verificare quanto affermato scrivendo proprio A1;B5 nella Casella Nome (ovvero quello spazio in alto a sinistra che normalmente mostra il nome della cella selezionata) e premendo il tasto Invio.

Il risultato sarà proprio quello che ci si aspetta: Excel selezionerà sia la cella A1 sia la cella B5 ovvero un totale di due celle.

Nota bene: per una questione di interfaccia, potrebbe essere difficile notare l’ultima cella selezionata ma la cosa funziona, chiaramente anche con un numero di celle superiore a due.

Se invece nella Casella Nome scriviamo A1:B5 (cioè separando i nomi delle due celle con i due punti) MS Excel selezionerà tutte le celle comprese fra la cella A1 e la cella B5 includendo queste due ovvero un totale di dieci celle.

Nota bene: a differenza dell’esempio precedente con il punto e virgola, questo funziona anche su tutte le versioni di Calc.

 

Pillole di Excel - 02 - punto e virgola, due punti e riferimento circolare

 

Vediamo un’applicazione pratica: utilizzando queste sintassi in una banale funzione di SOMMA, i risultati sono ovviamente molto diversi:

  • =SOMMA(A1;A5) darà come risultato 4 in quanto sommerà solo le celle A1 e A5
  • =SOMMA(A1:A5) darà come risultato 10 in quanto sommerà le celle A1, A2, A3, A4, A5.

 

Righe e colonne intere

Esiste anche una sintassi particolare (che funziona in MS Excel ma piano piano anche in Libre Office e Fogli Google) e che serve per far riferimento a intere colonne o a intere righe.

Scrivendo =SOMMA(A:A) si sommeranno tutte le celle della colonna A. Con =SOMMA(1:1) si sommeranno tutte le celle della riga 1 e così via.

È anche possibile contemplare più colonne o righe. Per esempio scrivendo =SOMMA(A:B) si sommeranno tutte le celle della colonna A e della colonna B.

 

Errore di riferimento circolare

Già che siamo qui, voglio che facciate la conoscenza di uno degli errori più frequenti in Excel: il Riferimento Circolare (su Calc chiamato Err:522).

Questo errore compare quando si fa riferimento alla cella nella quale si sta scrivendo l’operazione da effettuare.

Nell’esempio precedente, sarebbe apparso scrivendo nella cella C6 la seguente funzione: =SOMMA(A1:C6).

Excel avrebbe quindi provato a eseguire il calcolo ma sarebbe entrato in un loop, segnalandolo con un avviso.

Pillole di Excel - 02 - Errore di riferimento circolare - Lamberto Salucco

Su Calc l’errore è più facilmente visibile perché nella cella che lo ha generato rimane scritto “Err:522”, che è decisamente bruttino.

Quella carogna di Excel, invece, in conseguenza di questo errore si limita a visualizzare uno zero nella cella che contiene la formula/funzione incriminata (che ovviamente si mimetizza alla perfezione, specialmente in un foglio pieno zeppo di numeri) e lascia solo un minuscolo, invisibile, laconico “Riferimenti circolari:” seguito dal nome della cella che l’ha generato, nella Barra di stato.

Il rischio quindi è di scordarsi dopo pochi secondi dell’errore visualizzato, con conseguenze che potrebbero essere anche gravi.

Drammaticamente, qualora si crei un secondo Riferimento Circolare in un’altra cella, Excel non si scomoderà nemmeno a mostrare di nuovo l’avviso di errore: state attenti.

La prossima volta parliamo del dollaro.

 

 

Tratto da “Manabile Semiserio di Excel – Parte Prima per principianti

Qui il link per acquistare il libro su Amazon

Manabile semiserio di Excel, prima parteStrade scomparse di Firenze, prima parte - - Lamberto Salucco | Rebus Multimedia

Altri articoli

Prontuario semiserio di Digital Marketing – Lamberto Salucco

Edida ha pubblicato oggi il mio "Prontuario semiserio di Digital Marketing", ringrazio tutti. Si tratta...

FCT: “Caso baccelloni alieni”

Maramao Babonzi: “Tutto sotto controllo!” Getta acqua sul fuoco il sindaco Babonzi sulla presunta invasione...

Ep.51: “Una situazione complicata”

https://www.youtube.com/watch?v=R0E56dcYV6Y   I nostri eroi sono su un asteroide pieno di esplosivo che sta precipitando sulla...

Ep. 71: “La porta giusta”

Era una notte di metà autunno a Firenze City – lo sappiamo che nelle...

Pillole di Excel – 40 – Altre fx di testo 1

Bene, torniamo sulle funzioni di testo e parliamo adesso della funzione SOSTITUISCI. Basta essere dotati...

Pillole di Excel – 13 – Visualizza

Bene, in questo quinto capitolo cercherò di riunire le nozioni elementari relative alla visualizzazione...
spot_img

Lamberto Salucco

(Firenze, 1972) – Sono un consulente informatico (ma laureato in Lettere Moderne), mi occupo di marketing (ma solo digitale), social media (ma non tutti), editoria (ma non cartacea), musica (ma detesto il reggae), formazione (ma non scolastica), fake news (ma non sono un giornalista), programmazione (ma solo Python), siti web (ma solo con CMS), sviluppo app (ma solo iOS e Android), bias cognitivi (ma non sono uno psicologo), intelligence informatica (ma solo OSINT), grafica 3D (ma niente CAD), grafica 2D (ma niente Illustrator), Office Automation (ma non mi piace Access).
 

Forse ti potrebbe interessare anche: